Date: 22-10-20  Time: 16:46 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MFD

Pages: [1] 2
1
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 04 August 2019, 03:57:28 PM »
I cut out the immobiliser and all of its tendrils today, then went out for an hour or so without any issues. So hopefully thats the end of this saga!

2
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 03 August 2019, 03:45:05 PM »
I stuffed a bit of wire into the SS- wire at the ignition connector and went out for a couple more test rides.

Bike stubbornly refused to die on the first run, then started acting up on the second run. Confirmed ground connection at the ignition switch connector and not ECU when dead, furthermore, I measured 0.5v between the battery positive and switched ECU ground, as well as the ignition connector with ignition off, confirming the path from that connector to the immobiliser is sound.

Now I'm just debating if its worth the effort of getting some security torx bits to take the immobiliser apart in search of failed solder joints, blown caps, etc... or just ripping the thing out.

EDIT: After it started acting up, I shorted the ECU switched ground to permanent ground, no more drama for the rest of the way home.

3
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 03:14:00 PM »
You're definitely on the money Dudeness - I went out for a test run, with a bit of wire wedged in the SS ground on the ECU so I could probe it, died within 200yds, no ground. Engine starts up right away if I short the pin to ground, and then dies again when I remove the short.

After a while it decided to work again, and then died for a while after I dropped the seat back down. Wiggling the wiring around the rear of the tail doesn't seem to have any effect. The immobiliser still makes all its usual beeps and things when it won't start - so its power, ground and switched ignition are still good.

Considering it cut out when I placed the seat down, and it wasn't moving, I'm inclined to believe the fault may be in the immobiliser rather than the ignition switch - some kind of transistor-y thing breaking down, as it allows a small amount of current to go to ground when the bike is off. Any better ideas before I make a mess of the immobiliser harness to bypass it... and still have the problem?

4
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 02:17:01 PM »
Ruled a few of my possibilities out:

Break between kill switch and ignition coils
Starter cut-out relay (and diodes) are further back on frame than coils, break inside the main harness that cuts the coils off without also severing the starter relay further back is highly unlikely.

Break in wire from ignition to diode box
Fault in diode box

I tried starting the engine in gear with the clutch held in this morning, engine span, but didn't fire, which would require the ground returning from the clutch lever to the starter cut-out relay via the same wire used to ground the wire from SS- via the ignition switch, if I've understood the diagram properly.

Fault in crank sensor
Wiring to crank sensor looks good, and resistance is in spec. I'm assuming this is a hardy component and not prone to developing intermittent faults.

Leaving me with:

- Break in any ECU wires (power, grounds and crank sensor really)
- Break in wire from SS- to ignition
- Fault in immobiliser/alarm
- Fault in ECU

5
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 01:23:20 PM »
I made a simplified version of the Haynes wiring diagram, only showing things relevant for the ignition/starter/fuel pump/etc (can't seem to upload it right now)... and now I think I get it:

Spark requires ECU ground via alarm SS pins, which go to ignition switch, then to diode box, and to ground via side stand switch (when up) or neutral switch (when in neutral).

Starter requires starter cut-off relay to be grounded via neutral switch (in neutral), or clutch switch, then side stand switch (side stand up AND clutch lever pulled in).

I've confirmed the switched ground at the ECU is only grounded when the ignition is switched on AND the immobiliser is disarmed.

So I think that leaves me with the following possibilities:

- Break between kill switch and ignition coils
- Break in any ECU wires
- Break in wire from SS- to ignition
- Break in wire from ignition to diode box
- Fault in immobiliser/alarm
- Fault in ECU
- Fault in crank sensor
- Fault in diode box?!

The diagram also shows a wire from the neutral switch to the ECU, no idea what function that serves.

6
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 10:35:05 AM »
Right, stripped the tail down, propped the tank up and took side panels off.

I haven't found any (obviously) damaged wiring yet, but there is plenty of it disappearing where I can't see it. The immobiliser is very neatly installed - its been fully spliced and wrapped into the harness, which carries on past the ECU, round the back and down the other side to it. I probably couldn't remove it without having to cut the harness apart at the ECU and remaking some of the wires.

7
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 09:25:24 AM »
That escalated quickly...

Being the smart man that I am, I didn't bother putting the wiring diagram or multimeter in my bag today, after all, its only an infrequent fault, it probably won't manifest again for a while.

I made it perhaps 2-3 miles from home before it died, about one bend after overtaking a long line of cars. Did the usual playing around trying to restart, then pushed it up the hill and over the busy road to a garage to ask to borrow their multimeter... naturally the bike resumed working at this point, so I turned it around and headed back home.

Momentary cut out almost right away when turning off the road, then clear for perhaps another mile, until it did another momentary stall, then died completely. Repeat the wait-a-while-and-then-it-works dance, rode it off the curb of the pavement I'd parked on, no issue with the jolt from the drop, but then it packed in again all of about 50 yards later.

Pushed it to a pub, and waited a while again, finally decided to start up and made it the rest of the way home at 30-40 without issues.

While it was dead I jiggled the side stand, ignition and kill switches, with no effect. I couldn't see a spark between an extension bar I held in a plug cap and the cylinder head, also it backfired a couple of times after recovering, so pretty its on the ignition side now.

8
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 08:20:43 AM »
There's a Datatool immobiliser (maybe also an alarm?) fitted. Paperwork says it was fitted by an installer. I don't know whether it just plugs into the "Alarm" connector on the wiring diagram (seems pretty easy to bypass if so...), or splices into the harness in a dozen places... I'll probably find out this weekend.

After the bike cut out, the starter still turned, the engine just had no interest in firing, so either fuel or spark was gone from all 4 cylinders. I tried the starter when in neutral, and probably in gear with the clutch held in too.

9
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 02 August 2019, 12:08:47 AM »
Thanks for the suggestions. I'm going to try and get time to poke at all the wiring/connectors this weekend.

I've just been staring at the wiring diagram, but after half an hour the mess of diodes where the side stand and clutch switches meet the fuel pump and starter cut off relays still makes no sense. If the side stand or ignition switches went open circuit, taking out the coils, would I still be able to crank the starter?

10
FZS600 Fazer / Re: Infrequent cutting out and magical recovery
« on: 30 July 2019, 08:32:50 PM »
The fuel pump (I think) usually makes a few clicking noises when I first turn it on in the morning, has for as long as I've owned it.

There's normally no hesitation under sustained full power either, but I just remembered a few weeks ago the bike momentarily lost all power during an overtake.

11
FZS600 Fazer / Infrequent cutting out and magical recovery
« on: 30 July 2019, 07:08:59 PM »
Hello all,

After 18 months of (almost) flawless service, my FZS600 has decided to start impersonating my old Suzuki.

On the way home from work on Wednesday last week, while going up a hill, the engine just cut out with no warning, wasn't even trying to fire. After pulling over onto the pavement and turning it off/on a couple of times, it still wouldn't restart. After a couple of minutes of me taking my gear off I gave it another try, and it immediately fired on the first spin.

Fast forward to tonight, and it packed in not too far from home, same as before. Rode it down probably from 70ish to 20ish in gear, no life from the engine at all. Pushed it on a bit, still wouldn't start, pushed it on a bit more, still wouldn't start... until I was in sight of home.

There was no smell of fuel when cranking either time, and it didn't start with an almighty backfire like other times I've flooded in the past, so I'm inclined to believe its a fuel issue. Both times the fuel pump was silent for all the starting attempts, so I don't think it temporarily ran dry or was struggling to prime or anything like that.

Is there anything near the carbs that can shut off the fuel supply to all 4 cylinders, or am I barking up the wrong tree? Any other likely suspects?

Thanks

12
FZS600 Fazer / Re: Broken speedo drive and worn wheel bearings
« on: 27 November 2018, 02:50:08 PM »
Thanks for the link to the parts manual, very useful!

Picked up some bearings today, seals and new rotor should be arriving at a dealer tomorrow. Then just to see if the tyre fitter will foot the bill...

13
FZS600 Fazer / Broken speedo drive and worn wheel bearings
« on: 26 November 2018, 07:17:55 PM »
Evening all,

For the past couple of weeks I've had an intermittent squeak from the front of my 2003 FZS600, I thought it was just the calipers binding again as they've not had a proper strip down in my ownership. It got bad enough this morning that I could hear it when riding along at low-ish speeds, rather than just when in traffic as previously, then around ~40 on the way home this evening.

Took the front pads off tonight... still something rubbing on the wheel.

Took the wheel off... the lugs on the inner sleeve of the speedo drive were broken off and the whole thing was rather dry and smelling a bit burnt. I don't think it was lined up properly when I had the tyre replaced a few weeks ago, so the lugs broke off, but jammed in place so as to keep it turning, and put sufficient force on it to cook the grease away.

Yay.

Also both front wheel bearings have got a bit of a notch in them despite looking new, unsure if the sideways load from the wedged speedo drive could've caused that, or just normal wear.

Does anyone have the numbers for the right hand front wheel bearing and seal (couldn't read that side)? I'm going to drop by a bearing shop tomorrow to see if they can get me a replacement set.

I'm going to see if I can get the broken bits pegged back on, but failing that, does anyone happen to have a speedo drive assembly (or even just the inner sleeve) lying around?

Thanks

EDIT: Took a picture of the thing


14
FZS600 Fazer / Re: What have you done to your FZS600 bike today
« on: 07 October 2018, 05:10:17 PM »
Today I battled my way into the timing cover to check the valve clearances, all in spec... except ONE SODDING VALVE.

Debating leaving it since its <0.01mm too tight, but out of spec is out of spec...

15
FZS600 Fazer / Re: What have you done to your FZS600 bike today
« on: 07 October 2018, 11:06:00 AM »
What d'ya call that then, a Kim Kardashian seat?

I call it "I'm a special fragile snowflake and the standard seat isn't supportive enough", but I like your name too :D

16
FZS600 Fazer / Re: What have you done to your FZS600 bike today
« on: 06 October 2018, 05:59:36 PM »
Cleaned the sludge out from under the chain guard to stop it dripping back down and around the wheel, oiled the chain, then finally got round to making a proper top layer of foam for my seat:


Up next, a cover, to replace the bin bags I've been sitting on since February or so!

17
FZS600 Fazer / Re: What have you done to your FZS600 bike today
« on: 09 August 2018, 08:01:15 PM »
I've been getting achey hands on the Fazer which have gotten worse over time and I keep catching myself leaning on them, so on some advice I got a set of bar risers to try out:


Bars are currently spaced 20mm away, the kit includes extra 5mm and 10mm spacers to move them even further if necessary, but this is already pushing the brake hose a bit, so I'll have to get a longer one made if I stick with them. Rest of the cables have plenty of slack, and the bar mounts being angled means it doesn't hit the fairing at full lock :)

That gap is bothering me though... I'll have to get a deeper clamp top and skim it to fit!

18
FZS600 Fazer / Re: Chaaaaiiiiin
« on: 26 July 2018, 11:10:34 PM »
Just dug the tool out and this is the kind I used. Its rather comical to watch some of the tools spinning around off-center as you wind the bolt in.

Having spent the past couple of hours looking at chain riveters, the KM500 tool (and some of its knockoffs) seem to come highly recommended, and I like the look of how they work. I've read in several places that the VX chains require use of the super duper newer KM500R tool, which has a (somehow) slightly different pin, I'm not sure how much to trust that though.

19
FZS600 Fazer / Chaaaaiiiiin
« on: 26 July 2018, 08:54:29 PM »
Just did a (too) quick adjustment of my chain, took it out for a test run around the block and when I got back it was hot to touch (goes tight-slack-tight-slack as the wheel turns) :eek

Its too unevenly worn to get in spec through its full rotation, so I'm looking at ordering a DID 530VX chain, but DID don't make split links for them. Last time I tried fitting a rivet link (on a DID 520 or 525VX), the head of the rivet failed and sheared sideways before mushrooming out to the expected diameter, I'm not sure if it was bad luck and I got a faulty link, the budget chain riveter I was using, or somehow my technique. Luckily a local shop had a split link for it.

Has anyone else had a chain rivet fail using one of the budget tools? I don't really want to spend £100+ on a professional riveting tool, but if thats what it takes...

Alternatively I could relive my 125 days and get a plain chain without any kind of seals...

20
General / Tool storage
« on: 07 April 2018, 01:32:14 PM »
Thought I'd sort out a tool kit to keep on the Fazer today, so got out the kit I used to carry under the seat on my old GS500 and...


The tray under the seat of the GS was pretty bad; it'd end up with water and dirt from the road under it sometimes. So the tools were wrapped in plastic bags (which wore through) and then a rag, which mostly kept water /in/ rather than out from the looks of it.

The fazer under-seat tray looks clean, so hopefully I'm already ahead, but any bright ideas on bags/etc for storing tools in which might actually keep them dry? Ideally ones which could keep a thin mist of oil inside them too.

Thanks


21
General / Re: what did you do with your fazer today ?
« on: 06 April 2018, 06:35:47 PM »
Fitted a new battery and front sprocket+nut. Sprocket cover went back on with about half of the gasket that was there when I took it off last time.

Never seen a bike with a gasket around the sprocket cover before, is it worth worrying about replacing it? The back and bottom of its open anyway...

22
Eh, ordered a new plain sprocket for the sake of £12, the nylon can't be doing much damping on mine anyway.

Stay tuned for it somehow rattling like a set of tracks.

23
Thanks for the replies, that clears that mystery up.

bandit - Do you suggest replacing the sprocket just because the nylon has broken up? I see no reason not to do it at the same time, but if I change the front sprocket I'll be tempted to do the chain at the same time, then the rear sprocket too (both worn, but not enough that I'd normally replace them yet)...

As for nylon vs. plain steel sprocket, does the nylon ring make much of a difference? I'm guessing it only has an impact when switching between acceleration and overrun since the teeth would keep the chain loaded sideways the rest of the time?

24
FZS600 Fazer / Checked under my sprocket cover today... what is this?
« on: 22 March 2018, 02:29:22 PM »
So I finally got round to taking the sprocket cover off to check the nut today, and I've not seen a sprocket like this before.


It looks like some kind of plastic or resin was moulded around the sprocket, going out so far that the remaining parts touch the chain side plates. What weirdness have I stumbled onto?

I've also got the old 9mm thick nut, which I've read should be upgraded to a 12mm thick one, but there's only ~1mm of thread exposed on  the end of the output shaft. Do I need to change more than just the nut and locktab?

Thanks

25
For Sale & Wanted / For sale: Suzuki GS500
« on: 19 February 2018, 04:11:15 PM »
For sale a 2005 Suzuki GS500, selling because I got the Fazer.

The frame could do with some paint in places and there are multiple cosmetic knocks from a previous life as a school bike, but goes/stops fine and will get you where you want to go. There's a rattle from the engine which is most noticable at tickover, I'm 99% sure this is just camshaft endfloat, as these engines are prone to.

Has recently had a new battery and the tyres/pads/chain/sprockets have plenty of life left in them.

Comes with two keys, service history and MOT until mid-June.

I have a Haynes manual for it and a new oil filter which I will throw in if the buyer wants them.

Milage is 50k.

Bike is in West End, Southampton.

Offers in the region of £650 please.


Pages: [1] 2