Fazer Owners Club - Unofficial

Bits and bobs => Articles => FZS600 => Topic started by: coolhandluke on 22 May 2015, 09:39:18 AM

Title: KOSO Speedo
Post by: coolhandluke on 22 May 2015, 09:39:18 AM
Alright folks, Im wiring up a Koso speedometer and dont know how to wire it to the ignition as it doesnt have an on/off switch like heated grips for example so cannot be wired directly to the battery. I am an electricial invalid so please explain in simple terms and if possible provide pics!! cheers
Title: Re: KOSO Speedo
Post by: anutz on 22 May 2015, 04:52:19 PM
OK so i am in the middle of a project to re-wire the headlight loom to fit my DB-01r Plus....


I have to fit new speed sensor and magnets


I have to fit the in-line RPM sensor


Biggest headache is am going to cut the connector off the current loom ( spare off ebay ) and crimp the connectors on for the new speedo AMP connector to plug it all neatly in..


Then i have to shorten the headlight wires etc...


So what i thought was simple is a little more drawn out..


First off - what is the gauge, model no


Also you will have to at some point join the speedo onto the new headlight loom or splice wires in or join them in some other way and thus it will carry the old switched live and ground i assume?


 :)
Title: Re: KOSO Speedo
Post by: coolhandluke on 26 May 2015, 09:33:45 AM
i scotched cliped the live from the from the fuse box which came out were the ignition fuse was and ran a wire under the tank and along the original loom. i also used scotch clips to join the indicators, fuel, oil and high beam from the original loom to the koso one and i have made my own ground. only problem i have now is i have attached the rpm wires to the ignition coils as shown in the instructions but the revs aren't showing on the screen.  :'(  i have the same koso as you btw its a db-01.
Title: Re: KOSO Speedo
Post by: Hoppy on 01 August 2015, 04:52:43 PM
any one know how i can put a message on to all the message board ask for a  members name ?,am i missing something [quote hoppy
i scotched cliped the live from the from the fuse box which came out were the ignition fuse was and ran a wire under the tank and along the original loom. i also used scotch clips to join the indicators, fuel, oil and high beam from the original loom to the koso one and i have made my own ground. only problem i have now is i have attached the rpm wires to the ignition coils as shown in the instructions but the revs aren't showing on the screen.  :'(  i have the same koso as you btw its a db-01.
author=coolhandluke link=topic=17048.msg197119#msg197119 date=1432629225]
i scotched cliped the live from the from the fuse box which came out were the ignition fuse was and ran a wire under the tank and along the original loom. i also used scotch clips to join the indicators, fuel, oil and high beam from the original loom to the koso one and i have made my own ground. only problem i have now is i have attached the rpm wires to the ignition coils as shown in the instructions but the revs aren't showing on the screen.  :'(  i have the same koso as you btw its a db-01.