Date: 21-05-19  Time: 18:07 PM

Author Topic: Neutral light "problem fixed"  (Read 225 times)

M4RTIN

  • CBT Wobbler
  • *
  • Posts: 39
    • Main bike:
      Other
    • - ZX9R F2P & ZX9R C2 & Fazer 6
    • View Profile
Neutral light "problem fixed"
« on: 11 March 2019, 08:42:28 AM »
Ok, I have not long ago rebuilt the wife Fazer 6. Now i did not know it was a fault until i did some reading online.
The problem is when the bike is in gear and the clutch is pulled in, the neutral light comes on.
Now i have replaced the clutch lever switch, side stand switch and tried another second hand relay.
So even after doing this the neutral light still comes on when the clutch lever is pulled.
The bike has not got wet and has not been on the road yet.
Any help please would be great as sorting this problem out will keep the wife happy.

Mart
« Last Edit: 18 March 2019, 07:24:09 PM by M4RTIN »

agricola

  • Club Racer
  • ****
  • Posts: 457
  • Man on a mission
    • Main bike:
      FZ6 S2 07-09
    • View Profile
Re: Neutral light
« Reply #1 on: 11 March 2019, 07:01:47 PM »
Is it a Mk1 fazer, Fz6 fazer, or FZ6 S2 fazer?

M4RTIN

  • CBT Wobbler
  • *
  • Posts: 39
    • Main bike:
      Other
    • - ZX9R F2P & ZX9R C2 & Fazer 6
    • View Profile
Re: Neutral light
« Reply #2 on: 13 March 2019, 06:47:58 PM »
Its a Fazer 6 which is 2004 -2006

Grahamm

  • GP Hero
  • ******
  • Posts: 5,279
    • Main bike:
      FZ6 04-06
    • View Profile
    • Affordable Leather Products
Re: Neutral light
« Reply #3 on: 13 March 2019, 08:37:37 PM »
I've had the issue with the Neutral Light staying on when the bike has got wet, but if it's not got wet, I'm not sure what to suggest.

You could try checking the connection in the wiring loom and see if that's dodgy.

agricola

  • Club Racer
  • ****
  • Posts: 457
  • Man on a mission
    • Main bike:
      FZ6 S2 07-09
    • View Profile
Re: Neutral light
« Reply #4 on: 13 March 2019, 08:54:10 PM »
To check the neutral switch: located at the back of the engine.

Disconnect the connector
Bike in neutral
Ignition ON, light should be off, if on the lead between the connector and the instrument panel must be earthing somewhere
Check continuity between the switch terminal and the crankcase, with the bike in neutral, there should be continuity. in gear there should be no continuity. If not check the switch plunger
If the switch is good, check thw wiring check wiring between the connector/starter circuit cut off relay/instrument cluster
Check for battery voltage at the light green terminal on the cut off relay side of the instrument cluster wiring connector with the ignition ON. If no voltage there, check continuity between the connector and the ignition fuse

M4RTIN

  • CBT Wobbler
  • *
  • Posts: 39
    • Main bike:
      Other
    • - ZX9R F2P & ZX9R C2 & Fazer 6
    • View Profile
Re: Neutral light
« Reply #5 on: 18 March 2019, 07:23:02 PM »
FIXED
It was the connector on the neutral switch at the back of the engine. I moved it about and now the neutral light does not come on when the clutch is pulled in.  many thanks for the help. 


Big day tomorrow. MOT book in for 12.30pm  first MOT since the rebuild.  wanted to get this problem fixed before i had it done.
« Last Edit: 18 March 2019, 07:26:17 PM by M4RTIN »

agricola

  • Club Racer
  • ****
  • Posts: 457
  • Man on a mission
    • Main bike:
      FZ6 S2 07-09
    • View Profile
Re: Neutral light "problem fixed"
« Reply #6 on: 18 March 2019, 08:40:32 PM »
Well done

M4RTIN

  • CBT Wobbler
  • *
  • Posts: 39
    • Main bike:
      Other
    • - ZX9R F2P & ZX9R C2 & Fazer 6
    • View Profile
Re: Neutral light "problem fixed"
« Reply #7 on: 19 March 2019, 02:05:12 PM »
Well the 6 passed it first MOT, and it was the first time i had rode it. It's quick above 8k for a little 600cc bike.